Mozilla Labs 「Weave 0.2」を公開

「Weave 0.20」が公開され、これまでよりも多くのものを同期できるようになり、同期もこれまでよりは軽快になったということでしたが、まだまだ評価版の0.2ということで正式版の1.0への道のりは遠いわけでした。

すでに各所で導入方法は紹介されていますのでここでは割愛^^;

Mozilla Labs / Weave

0.1から利用の場合にはサーバーの仕様が変わったとかで改めてアカウントを設定する必要があります。

ウチの場合困ったのが、Ubuntu 8.04だとうまく動かないってことでした。上記のリンクには導入方法とかがなくて、とりあえずフォーラム覗いてみたらLinuxの場合は・・・的なことはあるんだけどいまいち要領を得ない。もちろん英語がネックって話もあるわけですがね。

ようやく見つけたのが、

Labs/Weave/FAQ – MozillaWiki

これ。

How do I make Weave work in Ubuntu 8.04 Hardy Heron?
1. Uninstall Weave from Firefox. Close Firefox.
2. Install updated and fixed versions of libnss and libnspr:
NSS:

(i386) http://launchpadlibrarian.net/15726878/libnss3-1d_3.12.0.3-0ubuntu0.8.04.1%7Emt1_i386.deb
(amd64) http://launchpadlibrarian.net/15726871/libnss3-1d_3.12.0.3-0ubuntu0.8.04.1%7Emt1_amd64.deb
NSPR:

(i386) http://launchpadlibrarian.net/15727099/libnspr4-0d_4.7.1%2B1.9-0ubuntu0.8.04.2%7Emt1_i386.deb
(amd64) http://launchpadlibrarian.net/15727094/libnspr4-0d_4.7.1%2B1.9-0ubuntu0.8.04.2%7Emt1_amd64.deb
These versions are also available in the “hardy-proposed” repository and will soon be in “hardy-updates” as well.
3. (64-bit only) If you are using 64-bit Ubuntu (amd64), you need to build Weave yourself, because the official build is 32-bit-only for now. It’s easy, just follow the instructions on this page: http://wiki.mozilla.org/Labs/Weave/Building
4. Install Weave in Firefox.

どうやら、パッケージが足りないというかバージョンが古いらしい。すぐにアップデートが入るだろうとありますが、せっかくインストールして使えないまま放置しておくのは気持ち悪いので上記の対処方法に則ってレッツトライ!

最初にWeaveのアンインストールってのが悲しい。アンイストールしてFirefoxを終了させる前に足りないパッケージをダウンロード。

パッケージのインストールをしようとすると、パッケージマネージャにこれより古いけど安定してるバージョンが提供されてるよと言われますが、それじゃ動かないからパッケージ落としてきてるんじゃい!と続行。2つとも同じことを言われます。

パッケージをインストールして、Firefoxを起動、WeaveをインストールしてFirefoxを再起動。

ステータスバーにあるWeaveアイコンをクリックしてもうんともすんとも・・・メニュー→ツール→Weaveでもさっぱり。

メニュー→編集→設定でようやくWeaveの設定画面に・・・。アカウントは作ってあるから他のコンピュータで使ってますよという方を選択してみるとパスフレーズで弾かれる・・・。何度やってもダメ。

仕方ないのでアカウントを新規に作り直す・・・メールアドレスを変えないといけない。別のメールアドレス、ユーザーネームももちろん新しいのにしてようやくアカウントの設定が完了。サインインして同期が始まったぁ!これまたいつまでかかるのだ?まぁ最初だから仕方ないか・・・しばらく放置。どうにか同期というか1台目なのでサーバーにデータ送った状態になりました。

やっと使えるようになったぁ!あとはもう1台・・・。最初の1台と同じ手順で進めるも、サインインは出来るけど同期がうまくいかないようだ。

結局、ウチでは現在使いものになってません。「Google Browser Sync」ってすごかったのねぇとしみじみ。
やっぱり正式版までの道のりは遠いというバージョンですね。